Global Payments SSL Certificate Update - All Users!

Global Pay SSL Certificate Upgrade Update - All Users

 

*UPDATE - Global Payments has extended the deadline for the SSL Certificate shutdown from November 18th to December 5th. Datacap will extend the discounted NETePay and Tran upgrades to coincide with this new deadline. 

 

9-30-2013

To improve network security, in response to increasing market and industry security requirements, transaction processing services using SSL gateways have been mandated to discontinue use of security certificates less than 2048-bit. These certificates validate the server’s identity and protect the data being transmitted. Global Payments is upgrading the SSL certificates used with IP/internet transactions thru the Global @dvantage IP gateway from 1024-bit to 2048-bit certificates. Global Pay began the migration April 1, 2013 by supporting both strength certificates, and plan to complete it on December 5, 2013 for US and Canadian locations, only supporting the 2048-bit certificates from those points forward. Merchants using the Global SSL gateway who are not upgraded to use the new 2048-bit certificates by December 5th may no longer be able to process transactions.  

Datacap has upgraded products using the Global Pay SSL gateway to support the new 2048-bit certificates, and Datacap product versions being deployed and upgrades over the past several months have been using the new 2048-bit certificates. Previous Datacap IP product versions used with Global Pay must be upgraded to use the new 2048-bit certificate, and need to be upgraded prior to Global Pay’s cutover completion dates to be able to continue to process transactions. Global Payments internet processing locations not upgraded to use the new certificates may not be able to process transactions, and will not be deemed to be PCI PA DSS compliant.

Global Payments is directly contacting merchants using systems that require upgrade to support the new certificates and notifying them that an upgrade is necessary, and asking them to contact their system provider/supporter. Upgrades can be easily and conveniently arranged and performed using PSCS™, Datacap’s cloud-based system for software downloads and parameter management. Products deployed or upgraded within the past 12 months will not incur upgrade fees for this upgrade, nor will Datacap products deployed under Datacap product usage/rental programs.  For other locations using Global Payments SSL gateway, very reduced, nominal upgrade fees are available thru December 5th to support Global Payments’ upgrade initiative and to strongly incent merchants to upgrade before then.  After those deadline dates, standard upgrade fees will apply, which are substantially higher.  

Global Pay NETePay™ versions 5.05 for US host based, US terminal based and Canadian host based installations support the new 2048-bit certificate.  Global Pay NETePay locations installed with versions prior to 5.05 need to upgrade to version 5.05. This upgrade will also have the added benefit of updated PA DSS 2.0 validation.

Global Pay IPTran™ and TwinTran™ version 3.0 release 3.72 for US host based and US terminal based installations support the new 2048-bit certificate.  Locations using Global Pay IPTran and TwinTran versions prior to release 3.72 need to upgrade.

There is no impact of the certificate change on locations using Global Pay DataTran (only) or DialTran. Also, legacy locations using DataTran with an attached IPTran do not check certificates and will not fail for this reason.  However, Global Pay DataTran/IPTran configuration users should consider upgrading to TwinTran to meet the latest card processor compliance requirements.

Please contact your POS provider or Datacap representative if there are questions.