New NETePay™ 5.0 and NETePay 4.0 PCI-SSC V1.2 Validated

Chalfont, PA - Datacap’s new NETePay 5.0 Integrated Payments software for PC-based POS systems has been validated under the latest PCI SSC PA-DSS V1.2 requirements. NETePay 4.0 was also re-validated under the same standard. NETePay 5.0 and 4.0 can be found alongside Datacap’s Tran product line, for embedded systems, on the PCI Security Council’s website.

PCI DSS (Payment Card Industry Data Security Standards) is a set of comprehensive requirements for enhancing payment account data security and preventing credit card fraud and related illegal activities. The standards were developed by the PCI Security Standards Council, a cooperative forum of the major payment card brands, to help facilitate broad adoption of consistent data security measures on a global basis.

For a merchant to comply with PCI DSS they must use fully PA-DSS compliant POS and payment solutions as well as follow PCI DSS standards for implementing them and protecting card holder data in day to day operations. While compliance is a current requirement for all merchants, processors and acquirers are now checking merchant applicants to affirm that the employed payment application is currently validated under the latest PCI SSC standard.

For additional information regarding PA-DSS compliance, contact your Datacap representative, your POS provider or visit:

https://www.pcisecuritystandards.org/