Moneris NETePay™ 4.0 Certified and Now Available

Chalfont, PA - Moneris NETePay 4.0 has been certified and is now available for new installs or upgrades. Most importantly of the updates in version 4.0 is that it is PCI PABP validated, enabling users to more easily become PCI compliant. Other updates include improved PIN pad security and a pre-authorization upgrade to avoid potential downgrades (check LogiVision for other key update).

PCI validation is an important card association and industry initiative aimed at protecting cardholder information and avoiding fraudulent card usage. To be PCI compliant, merchants must use compliant solutions in a compliant manner, which often requires operational and procedural changes in cardholder information handling, as well as compliant and validated POS and payment software versions. Retailers who are not compliant and are compromised are subject to substantial associated fees and penalties. Additional information about PCI requirements, compliance and validation is available in NETePay installation guides, from your Datacap representative or at www.datacapsystems.com. Information is also available from many other sources; www.visa.com and www.pcisecuritystandards.org

Current Moneris NETePay users can order upgrades from the Datacap sales department.

 

Contact your Datacap representative for additional details.

(215) 997-8989 or Sales@dcap.com